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Navigating around the space
• Refer to the C4D Interface handout.
• Open Cinema 4D.
• Go to top menu bar to the Object Creation section. Left click on the cube icon, then
select a cube. This is a primitive/parametric object.
• Observe that the Object Manager now has a Cube in it. Also observe the information
about the cube in the Attribute Manager and Coordinate Manager.
• Save your c4d file and give it a name.
• The undo and redo buttons are the first buttons on the top menu bar.
• Observe the axes: red is x-axis, blue is z-axis and green is y-axis. This is the standard
orientation for 3D visualization, but is the reverse orientation of the axes from math
classes.
• Practice moving around in space.
– Hold 1 and left click: allows you to move in the three spatial dimensions.
– Hold 2 and left click: allows you to zoom in and out. (The wheel on the mouse
also lets you zoom.) The zoom is in the direction of the cursor. (See if you can
fly inside the cube.)
– Hold 3 and left click: allows you to rotate your viewpoint. The rotation is
centered on the spot your cursor is when you begin rotating.
• Practice moving an object in space. First select the object (right now this is a cube).
Look at the Navigation Tools on the left of the top menu bar.
– Click on the symbol that looks like xy-axes (the Move Tool). Then click on
your object and move it in any of the three spatial dimensions. Look at the
numbers in the Coordinate Manager (bottom right of the view-port). You can
precisely place objects by editing these numbers. See if you can shift the cube
up 20 cm and move it 50 cm in the z-axis direction.
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– Click on the next symbol along from the move tool. This is the Scale Tool.
You’ll notice the axes end with squares, not arrows. Scale the cube up and down
in size. Look at the numbers in the Coordinate Manager (bottom right of your
window). Scale your cube to have side length 10cm. Zoom in so you can see it
clearly.
– Click on the next symbol along from the scale tool. This is the Rotate Tool.
Practice rotating the cube in various directions. Use the undo buttons to return
the square to its usual orientation.

Basic commands
• Change the cube from a primitive object to an editable object. Click on top button
on the left hand menu, the Make Editable button. (This looks like two spheres
with an arrow.)
• Look at the Object manager. To the right of the word Cube is a picture of a cube.
After clicking the Make Editable button, the picture changes from a cube to a triangle
shape.
• The Modes Icon Palette is found on the menu on the left. There are 4 useful modes:
Model mode (directly below the Make Editable button), Point mode (a cube
with two points highlighted), Edge mode (a cube with an edge highlighted), and
Polygon mode (a cube with a face highlighted). Each of these modes allows you
edit the various properties of the cube (points, edges, faces).
– On the top menu in the Navigation tools, click on the Live Selection button
with an arrow in a round circle. This lets you select various objects and parts
of objects.
– Now experiment with each of the modes and see what happens.
– Note that you can change the size of the circle you see with Live Selection.
Under the Attribute Manager, simply increase or decrease the radius.
TIP: Forget what the various buttons do on the top and side menus? Simply hover the
mouse over the button. The name, and keyboard shortcut commands will appear.
TIP: Cinema 4D keeps track of which tools you are using. There is a Short Cut button
located at the right side of the Navigation Tools on the top menu, but to the left of the
button which has an X in a red circle. This button has some symbol on it (exactly which
one changes with what you have selected), with a black arrow in the bottom right corner.
Left click (and hold) this Short Cut button down. You will see a display of all the tools
you have recently used. This menu serves as useful shortcut to find tools after you have
first used them.
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Creating a .stl file
Once you are satisfied with your model, you can create a .stl file that a 3D printer can use.
• At the top left of the view-port go to File → Export → .STL (*.stl).
• Keep the scale as “1 Centimeter”.
• Save your .stl file.

Building a model with disks.
1. Open a new file and save it as three-disks.c4d
2. Left click on the Cube in the Object Creation part of the top menu, and select the
Cylinder: this will be your disk.
3. Go to the Cylinder icon in the Object Manager. Delete the two brown circles to the
right of the Cylinder.
(These are called Phong tags and have to do with how the surface is rendered. Notice
how the cylinder changes appearance. When 3D printing, we need to know what the
mesh actually looks like.)
4. Go the the Attribute Manager for the cylinder.
• Adjust the radius and height of the cylinder. Make r = 5 cm, h = 1 cm. Zoom
in so you can see the cylinder clearly.
• The cylinder’s coordinates are given by the central point of the cylinder (center
of the circle and half the height). Thus in order for the cylinder to sit flat on
the xz-plane, we need to shift the cylinder up 0.5 cm in the y-direction.
• Adjust the number of rotation segments to somewhere between 60 and 100.
Notice how this smooths out the appearance of the cylinder.
5. Save your file again!
6. Add another cylinder. This time make r = 4 cm, h = 1 cm. Shift the cylinder up
1.5cm (can you see why?). Don’t forget to delete the Phong tags and increase the
number of rotation segments.
7. Save your file again!
8. Add another cylinder. This time make r = 4.5 cm, h = 1 cm. Shift it up 2.5 cm
(can you see why?). Don’t forget to delete the Phong tags and increase the number
of rotation segments.
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9. Save your file again!
10. We will now join the disks together using two different methods. The start point for
each method will be the three-disks.c4d file you have just saved.

Connect the disks: Method 1
Remark: This method is a quick and dirty way of joining the disks into one object. Some
3D printers will NOT be able to correctly read the models produced from this file. This
method produces an object which is mathematically correct, but is not necessarily the most
elegant 3D print design.
1. Save a copy of the three-disks.c4d file under a different name, say three-disks-m1.c4d.
2. Go to the Object Manager and select all of the Cylinders. (Do this by holding the
Shift (or Command) key and clicking on each name.)
3. Make the cylinders editable (into polygons) by clicking on the Make Editable button
(with the two spheres and an arrow) found at the top of the left hand menu.
4. With all the objects still selected, go to the Mesh menu at the top of the viewport (near the rotate tool), then go to Conversion and select Connect Objects +
Delete. (Alternatively, you can right click and select Connect Objects + Delete).
5. This creates just one object in the Object Manager. Notice that you can move the
object as a whole.
6. Why is this object not a great design for 3D printing? Fly inside the object by
zooming in. Notice that you can see the walls between the slices. It’s these walls
that some 3D printers don’t like.

Connect the disks: Method 2 - Boole
Remark: This method is a more time consuming way of joining the disks into one object.
However the finished model has a beautiful 3D print design. The finished model won’t
be 100% mathematically correct. However the errors are so small, that once printed, this
model is indistinguishable from a mathematically correct model.
1. Open up your original three-disks.c4d file.
2. Save a copy of the file under a different name, say three-disks-m2.c4d.
3. The plan.
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(a) Make the middle cylinder slightly thicker so it overlaps (by a tiny amount) with
the other two cylinders.
(b) Use the Boole Tool to join the cylinders together.
4. Click on the middle cylinder (with radius 4 cm). In the Attribute Manager for the
cylinder, make the height 1.01cm.
• This tiny increase in the height causes the middle cylinder to overlap the other
two cylinders by a small amount.
• The height has been changed only by 0.01 cm, or 0.1 mm. This is a tiny amount
and within the thickness of the filament used to 3D print a model.
5. Go to the Object Manager and select all of the Cylinders. (Do this by holding the
Shift (or Command) key and clicking on each name.)
6. Make the cylinders editable (into polygons) by clicking on the Make Editable button
(with the two spheres and arrow) found at the top of the left hand menu.
7. Go to the Object Creation part of the top menu. Left click and hold on the green
shape that looks a bit like a flower. (This is the Array button.) Then select the
Boole tool (two overlapping circles).
8. Go to the Object Manager. Move two of the cylinders (say Cylinder.1 and Cylinder.2)
until they are under the Boole. (As you move the Cylinders in the Object Manager
you will see a down arrow appear when they are under the Boole.) Don’t panic when
one cylinder vanishes.
9. Click on the Boole in the Object Manager. Look at the Attribute Manager. Under
Boolean Type, change from “A Subtract B” to “A union B”. Notice that the cylinder
reappears.
10. In the Object Manager, select “Boole”, “Cylinder.1” and “Cylinder.2” (by holding
down the Shift key). Then go to the Mesh menu at the top left of the view-port (near
the rotate tool), then go to Conversion and select Current State to Object. An
L0 Boole will now appear in the Object Manager.
11. Delete the original Boole.
12. Drop down the menu for L0 Boole by clicking on the +. Hold down the Shift key
and select “L0 Boole”, “Cylinder.1”, and “Cylinder.2”. Go to the Mesh menu, then
go to Conversion and select Connect Objects + Delete. (Alternatively, you can
right click and select Connect Objects + Delete). You will be left with “Boole.1”
in the Object Manager.
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13. Don’t forget to save your work!
14. Pause a moment and Zoom in so you can see inside the two cylinders you have just
joined together. Notice that there is no interior wall! Zoom out again.
15. Join the remaining cylinder to the Boole.1 object by repeating steps (7) – (13).
WARNING 1: If your objects do not overlap by a tiny amount, then this Boole method
will not remove the walls between the objects. You may as well join the cylinders together
using Method 1.
WARNING 2: Once you have created a model using this method, you have deleted the
original objects used to construct the model. At this point, you can not return to these
objects later on.
It is for this reason that it is smart to keep a separate file with a copy of all
the original disks until you are satisfied with the model you have created.

Cinema 4D tips for more complex models.
Volumes by cylindrical shell method
1. Left click on the Tube Object in the Object Creation part of the top menu, and select
the Tube. This will be your cylindrical shell.
2. Go the the Attribute Manager for the Tube.
• Adjust the inner and outer radii, and the height of the tube.
• Adjust the number of rotation segments to somewhere between 60 and 100.
• Move the tube into its correct position (via the Coordinate Manager).
3. Repeat with other tubes. Save a file with all of the separate tubes as a
reference.
4. Join the tubes together. If using the Method 2 with the Boole Tool, then remember
to adjust the radii so the cubes are overlapping by a tiny amount.
TIP 1: If the innermost cylindrical shell has zero inner radius, then it is a cylinder. Use
the Cylinder object, rather than the Tube object here.
TIP 2: The tube’s coordinate are given by the central point of the tube (center of the
circle(s) and half the height).
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Volumes made of square slices
1. Left click on the Cube Object in the Object Creation part of the top menu, and select
the Cube.
2. With the cube selected, click on the Make Editable button.
3. Go to the Coordinate Manager.
• Adjust the size of the cube to be an appropriately sized square slice.
• Move the square slice into place.
4. Repeat with other square slices. Save a file with all of the separate square
slices as a reference.
5. Join the cubes together. If using the Boole Tool, then remember to adjust the height
so the cubes are overlapping by a tiny amount.

Volumes made of triangular slices
1. We first construct a triangle of the right size.
• Left click on the Tube Object in the Object Creation part of the top menu, and
select the Polygon.
• Go to the Attribute Manager and click on the Triangle button. (You can adjust
the height and width of your triangle here, or you can do it as described below.)
• With the Polygon selected, click on the Make Editable button.
• Click on the Point Mode button on the menu on the left hand side. This is
the cube with two vertices highlighted.) Click on the Live Selection button
on the top menu (the arrow in the red circle.)
• Click on one of vertices of the triangle. Use the Coordinate manager to move
the vertex to the correct position. Repeat with the other vertices.
2. We now thicken the triangle into a triangular slice.
• Click on the Polygon Mode button on the menu on the left hand side. (This
is the cube with a highlighted face.) Make sure the Live Selection button is
highlighted.
• Click on the triangle, it will turn a yellow color.
• Go to the Mesh menu, then go to Create Tools and select Extrude. Go to
the Attribute Manager. Change the “Offset” to be the thickness of your slice.
Click on the “Create Caps” button. Hit “Apply”.
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• Go to the Model Mode (right below the Make Editable button). Click on
Live Selection button. Go to the Coordinate Manager and, if necessary, move
the slice into position.
• Check that the slice is properly oriented. First go to Polygon Mode. Then
Control+A to select all of the faces on the triangular slice. (Alternatively go
to Select menu, then Select All.) All the faces on the triangular slice should
be an orange color. [If it is not, it will be a blue color. This means the slice is
inside out. To fix this, go to Mesh, then Normals, then Reverse Normals.]
3. Repeat this process with other triangular slices. Save a file with all of the separate triangular slices as a reference.
4. Join the triangular slices together. If using the Boole Tool, then remember to adjust
the height so the triangular prisms are overlapping by a tiny amount.
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